Narzędzie do rozwiązywania problemów z licencją oprogramowania Intel® FPGA

Często zadawane pytania

Często zadawane pytania

Użyj funkcji "Aktualizacja licencji internetowej", aby automatycznie pobrać i zainstalować najbardziej aktualny plik licencji. Kliknij przycisk Aktualizacja licencji sieci Web w oknie dialogowym Konfiguracja licencji (menu Narzędzia).

Jeśli nadal potrzebujesz pomocy, sprawdź sekcję konfiguracji pliku licencji "Jak sprawdzić konfigurację pliku licencji" na tej stronie dla swojego oprogramowania.

Musisz uzyskać plik licencyjny od firmy Intel i skonfigurować go do korzystania z oprogramowania programistyczne Intel® Quartus®.
Jeśli używasz oprogramowania deweloperczego Intel Quartus w wersji 3.0 i nie masz skonfigurowanego pliku licencji, możesz poprosić o plik licencji podczas uruchamiania oprogramowania.
Można również poprosić o plik licencyjny w Centrum licencjonowania intel FPGA.
Plik licencji jest wysyłany jako załącznik wiadomości e-mail. Zapisz plik licencji na dysku twardym. Firma Intel zaleca zapisanie pliku licencji w tym samym katalogu, w jakim jest używane oprogramowanie.

Jeśli nadal masz problem, należy sprawdzić, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia. Szczegółowe informacje na temat sprawdzania konfiguracji pliku licencji można znaleźć w sekcji "Jak sprawdzić konfigurację licencji" na tej stronie.

Często zadawane pytania

Często zadawane pytania

Czy oprogramowanie jest licencjonowane z identyfikatorem karty sieciowej lub dysku twardego?

Identyfikator karty sieciowej:Otwórz okno Konfiguracja licencji w oprogramowaniu programistycznym Intel® Quartus® (menu Narzędzia -> Konfiguracja licencji). Sprawdź, czy sekcja identyfikatora karty interfejsu sieciowego w polu Informacje o systemie jest zgodna z identyfikatorem karty sieciowej określonym w pliku licencji.

Identyfikator dysku twardego: Poniżej przedstawiono inne zasoby, których można użyć, aby rozwiązać problem, który może wystąpić w przypadku produktów Intel® FPGA.

Szukaj rozwiązań w Bazie wiedzy.

Przejrzyj dokumentację.

Instalacja i licencjonowanie oprogramowania Intel FPGA (PDF)

Podręcznik DSP Builder (PDF)

Prześlij zgłoszenie serwisowe do mySupport, systemu pomocy technicznej online firmy Intel.

Aby dowiedzieć się, czy oprogramowanie jest licencjonowane z identyfikatorem karty interfejsu sieciowego (NIC) lub identyfikatorem dysku twardego, otwórz plik licencji w edytorze tekstu.

Jeśli zawiera słowo HOSTID, po którym następuje 12-cyfrowy numer szesnastkowy, oprogramowanie jest licencjonowane z identyfikatorem karty sieciowej.
Przykład: HOSTID=00C04FA0B182 jest licencjonowany z identyfikatorem karty sieciowej.

Problemy licencyjne z T-Guards mogą wystąpić, jeśli T-Guard nie jest rozpoznawany przez oprogramowanie. Może się tak zdarzyć, jeśli port równoległy w komputerze nie jest skonfigurowany do stosowania w trybie ECP.
Sprawdź w systemie BIOS, czy port równoległy jest ustawiony na tryb ECP.

Czy oprogramowanie jest licencjonowane z identyfikatorem karty sieciowej lub dysku twardego?

Sprawdź ustawienia BIOS-u:Sterownik Sentinel musi być włączony dla portu równoległego, do którego podłączone jest T-Guard. Uruchom program setupx86.exe w katalogu \drivers.
Wybierz polecenie Konfiguruj sterownik Sentinel z menu Plik.
Upewnij się, że Użyj? Kolumna jest ustawiona na Tak dla portu równoległego.
Zamknij program Sentinel Driver i uruchom ponownie komputer.

Różne wersje systemu BIOS mają różne procedury tworzenia tego ustawienia. Skontaktuj się z dostawcą komputera, aby uzyskać pomoc.

Otwórz okno Konfiguracja licencji w oprogramowaniu programistycznym Intel® Quartus® (menu Narzędzia -> Konfiguracja licencji).
Sprawdź, czy sekcja identyfikatora karty interfejsu sieciowego w polu Informacje o systemie jest zgodna z identyfikatorem karty sieciowej określonym w pliku licencji. Aby identyfikator karty sieciowej był wyświetlany prawidłowo.

Jeśli potrzebujesz dalszej pomocy, możesz rozwiązać ten problem, dodając klucz w rejestrze systemu Windows. Użyj Edytora rejestru (regedt32.exe), aby wyświetlić następujący klucz w rejestrze: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

Dodaj następującą wartość rejestru:

Nazwa wartości DisableDHCPMediaSense
Typ danych REG_DWORD -Boolean
Wartość 1

Uruchom ponownie komputer, aby zmiana weszła w życie.

Ustawianie klucza rejestru DisableDHCPMediaSense

Problemy z licencjami sieciowymi mogą wystąpić z powodu problemów z konfiguracją na serwerze licencji.
Uruchom polecenie lmutil lmstat -a -c port@host gdzie port@host jest numer portu i nazwa hosta serwera licencji (na przykład 1800@server1).
Sprawdź dane wyjściowe polecenia. Menedżer licencji i demon Intel FPGA powinni zgłosić UP.
Oprogramowanie programistyczne Intel Quartus® w wersji 3.0 wymaga, aby oprogramowanie do zarządzania licencjami i demona Intel FPGA było wyższe niż 8.0.

Jeśli stan serwera licencji to OK, możliwe, że na komputerze klienckim występuje problem z konfiguracją.
Sprawdź, czy zmienna środowiskowa LM_LICENSE_FILE jest poprawnie ustawiona na komputerze klienckim.

Sprawdź zmienną środowiskową LM_LICENSE_FILE.

W systemie UNIX* wpisz env |grep LM_LICENSE_FILE i upewnij się, że wartość jest zgodna z lokalizacją pliku licencji.
W systemie Windows* wpisz | znajdź "LM_LICENSE_FILE" i upewnij się, że wartość odpowiada lokalizacji pliku licencji.
Aby uzyskać informacje na temat ustawiania zmiennej środowiskowej LM_LICENSE_FILE, zapoznaj się z notą dotyczącą aplikacji AN 340: Intel FPGA Software LicensingApplication Note.

Jeśli menedżer licencji i wersje atlerowane są niższe niż 8.0, firma Intel zaleca korzystanie z najnowszych wersji menedżera licencji (lmgrd) i demona dostawcy (Intel FPGA), które są dołączone do oprogramowania programisty Intel® Quartus®.

Zaktualizowane wersje plików są również dostępne do pobrania na stronie License Daemon Downloads.
Uruchom ponownie menedżera licencji po zaktualizowaniu plików.

Które oprogramowanie masz trudności z licencjonowaniem?

Często zadawane pytania

Często zadawane pytania

W zależności od tego, kiedy plik licencyjny wygaśnie, do korzystania z nowej wersji oprogramowania może być potrzebny nowy plik licencji. Plik licencyjny mógł wygasić.

Aby uzyskać nowy plik licencji dla programu Quarterus development softawre w wersji 4.0 lub nowszej, użyj funkcji "Web License Update", aby automatycznie pobrać i zainstalować najbardziej aktualny plik licencji.

Kliknij przycisk Aktualizacja licencji sieci Web w oknie dialogowym Konfiguracja licencji (menu Narzędzia). Zapoznaj się również z sekcją "Jak uzyskać nowy plik licencji" i wybierz "Oprogramowanie programistyczne Intel Quartus w wersji 4.0 lub nowszej".

Aby uzyskać plik licencji dla wersji 3.0 lub starszej, musisz uzyskać plik licencji od firmy Intel i skonfigurować go do korzystania z oprogramowania programistyczne Intel® Quartus®.

Jeśli używasz oprogramowania deweloperczego Intel Quartus w wersji 3.0 i nie masz skonfigurowanego pliku licencji, możesz poprosić o plik licencji podczas uruchamiania oprogramowania.
Można również poprosić o plik licencyjny w Centrum licencjonowania intel FPGA.
Plik licencji jest wysyłany jako załącznik wiadomości e-mail. Zapisz plik licencji na dysku twardym. Firma Intel zaleca zapisanie pliku licencji w tym samym katalogu, w jakim jest używane oprogramowanie. Możesz również zapoznać się z sekcją "Jak uzyskać nowy plik licencji" i wybrać "Oprogramowanie programistyczne Intel Quartus w wersji 3.0 lub wcześniejszej".

Jeśli zainstalowano już nowy plik licencji, sprawdź, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia.

Aby sprawdzić konfigurację pliku licencji, zapoznaj się z sekcją "Jak sprawdzić konfigurację pliku licencji" i wybierz jedno z poniższych programów.

  • Intel® Quartus® Lite Edition
  • Oprogramowanie programistyczne Intel Quartus z osłoną T-Guard
  • Oprogramowanie programistyczne Intel Quartus dołączone do zestawu programisty
  • Oprogramowanie deweloperskie Intel Quartus z serwerem licencji sieciowej

T-Guard to klucz sprzętowy lub klucz sprzętowy, który podłącza się do równoległego portu komputera.

Jeśli nadal potrzebujesz pomocy, wykonaj poniższe czynności.

Otwórz okno Konfiguracja licencji (menu Narzędzia -> Konfiguracja licencji). Pole Plik licencji musi mieć określoną ścieżkę do pliku licencji lub port@host serwera licencji. Jeśli chcesz przejść do pliku licencji, kliknij przycisk [. . .] i wybierz plik licencji na dysku twardym.

Przykłady prawidłowych wartości pól pliku licencji:

Ścieżka do pliku licencji: c:\quartus\license.dat

port@host: 1800@server1

Aby korzystać z oprogramowania deweloperczego Intel® Quartus® należy skonfigurować plik licencji. Możesz poprosić o plik licencyjny w witrynie firmy Intel, jeśli jeszcze go nie masz.

Aby uzyskać nowy plik licencyjny, zapoznaj się z sekcją "Jak uzyskać nowy plik licencyjny" na tej stronie.

Jeśli plik licencji został już zainstalowany, sprawdź, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia. Aby sprawdzić konfigurację pliku licencji, zapoznaj się z sekcją "Jak sprawdzić konfigurację pliku licencji" na tej stronie.

Oprogramowanie przestanie działać po wygaśnięciu pliku licencji.

Plik licencyjny mógł wygasić. Uzyskaj nowy plik licencyjny omówiony w poprzedniej sekcji "Jak uzyskać nowy plik licencji".

Jeśli plik licencji nie wygasł, sprawdź, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia. Veirfy oprogramowanie jest wskazywane na licencję. Aby uzyskać informacje o tym, jak to zrobić, zapoznaj się z sekcją "Jak sprawdzić konfigurację pliku licencji".

Jeśli problem nadal występuje, wykonaj poniższe czynności:

Otwórz okno Konfiguracja licencji (menu Narzędzia -> Konfiguracja licencji). Pole Plik licencji musi mieć określoną ścieżkę do pliku licencji lub port@host serwera licencji.
Jeśli chcesz przejść do pliku licencji, kliknij przycisk [. . .] i wybierz plik licencji na dysku twardym.

Przykłady prawidłowych wartości pól pliku licencji:

Ścieżka do pliku licencji: c:\quartus\license.dat

port@host: 1800@server1

Często zadawane pytania

Często zadawane pytania

Wybierz jedno z poniższych programów Quartus, których używasz, aby uzyskać szczegółowe informacje:

Oprogramowanie Intel Quartus Prime Pro i Standard Edition

Licencja ModelSim*-Intel FPGA jest ograniczona czasowo. Plik licencyjny mógł wygasić. W takim przypadku należy odnowić subskrypcję oprogramowania firmy Intel. Możesz to zrobić za pośrednictwem sklepu internetowego Intel.

Jeśli stan serwera licencji zostanie sprawdzić, może to być problem z konfiguracją na komputerze klienckim. Sprawdź, czy zmienna środowiskowa LM_LICENSE_FILE jest poprawnie ustawiona na komputerze klienckim.

W systemie UNIX wpisz: env |grep LM_LICENSE_FILE. Upewnij się, że wartość jest zgodna z lokalizacją pliku licencji.
W systemie Windows wpisz: ustaw | znajdź "LM_LICENSE_FILE". Upewnij się, że wartość jest zgodna z lokalizacją pliku licencji.
Aby uzyskać informacje na temat ustawiania zmiennej środowiskowej LM_LICENSE_FILE, zobacz AN 340: Intel FPGA Software Licensing Application Note).

Oprogramowanie Intel Quartus Prime Lite Edition

Oprogramowanie ModelSim* - Intel FPGA nie jest dołączone do Intel® Quartus® Prime Lite Edition ani do płytek deweloperskich. Aby uzyskać licencję ModelSim*-Intel FPGA, musisz wykupić pełną subskrypcję oprogramowania Intel® FPGA. Pełną subskrypcję można kupić w sklepie internetowym firmy Intel.

Oprogramowanie programistyczne Intel Quartus z zestawem programistycznym

Oprogramowanie ModelSim* - Intel FPGA nie jest dołączone do Intel® Quartus® Prime Lite Edition ani do płytek deweloperskich. Aby uzyskać licencję ModelSim*-Intel FPGA, musisz wykupić pełną subskrypcję oprogramowania Intel® FPGA. Pełną subskrypcję można kupić w sklepie internetowym firmy Intel.

Dotarłeś do końca tego narzędzia do rozwiązywania problemów:

Poniżej przedstawiono kilka innych zasobów, których można użyć, aby rozwiązać problem, który może występować z produktami Intel FPGA.

Szukaj rozwiązań w Bazie wiedzy.

Przejrzyj dokumentację.

Instalacja i licencjonowanie oprogramowania Intel FPGA (PDF)

Podręcznik DSP Builder (PDF)

Prześlij zgłoszenie serwisowe do mySupport, systemu pomocy technicznej online firmy Intel.

Firma Intel może dostarczyć licencję ModelSim*-Intel® FPGA dla Verilog lub VHDL.

W pliku licencji sprawdź, dla jakiego języka jest przeznaczona licencja.

Jeśli język używany do symulacji w układzie FPGA ModelSim*-Intel nie jest zgodny z licencjonowanym językiem, skontaktuj się z działem obsługi klienta firmy Intel za pośrednictwem mySupport.

Poniżej przedstawiono kilka innych zasobów, których można użyć, aby rozwiązać problem, który może występować z produktami Intel FPGA.

Szukaj rozwiązań w Bazie wiedzy.

Przejrzyj dokumentację.

Instalacja i licencjonowanie oprogramowania Intel FPGA (PDF)

Podręcznik DSP Builder (PDF)

Prześlij zgłoszenie serwisowe do mySupport, systemu pomocy technicznej online firmy Intel.

Aby sprawdzić licencjonowany język, otwórz plik licencji.dat wysłany przez firmę Intel. Poszukaj INCREMENT alteramtivsim lub INCREMENT alteramtivlog. Pierwszy wskazuje licencję VHDL, a drugi wskazuje licencję Verilog. Aby uzyskać więcej informacji na temat formatu pliku licencji, przejdź do sekcji Format pliku licencji AN 340: Intel FPGA Software Licensing (PDF).

Często zadawane pytania

Często zadawane pytania

W zależności od tego, kiedy plik licencyjny wygaśnie, do korzystania z nowej wersji oprogramowania może być potrzebny nowy plik licencji.

Plik licencyjny mógł wygasić.

Aby uzyskać nowy plik licencji dla programu Quarterus development softawre w wersji 4.0 lub nowszej, użyj funkcji "Web License Update", aby automatycznie pobrać i zainstalować najbardziej aktualny plik licencji.

Kliknij przycisk Aktualizacja licencji sieci Web w oknie dialogowym Konfiguracja licencji (menu Narzędzia). Zapoznaj się również z sekcją "Jak uzyskać nowy plik licencji" i wybierz "Oprogramowanie programistyczne Intel Quartus w wersji 4.0 lub nowszej".

Aby uzyskać plik licencji dla wersji 3.0 lub starszej, musisz uzyskać plik licencji od firmy Intel i skonfigurować go do korzystania z oprogramowania programistyczne Intel® Quartus®.

Jeśli używasz oprogramowania deweloperczego Intel Quartus w wersji 3.0 i nie masz skonfigurowanego pliku licencji, możesz poprosić o plik licencji podczas uruchamiania oprogramowania.
Można również poprosić o plik licencyjny w Centrum licencjonowania intel FPGA.
Plik licencji jest wysyłany jako załącznik wiadomości e-mail. Zapisz plik licencji na dysku twardym. Firma Intel zaleca zapisanie pliku licencji w tym samym katalogu, w jakim jest używane oprogramowanie. Możesz również zapoznać się z sekcją "Jak uzyskać nowy plik licencji" i wybrać "Oprogramowanie programistyczne Intel Quartus w wersji 3.0 lub wcześniejszej".

Jeśli zainstalowano już nowy plik licencji, sprawdź, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia.

Aby sprawdzić konfigurację pliku licencji, zapoznaj się z sekcją "Jak sprawdzić konfigurację pliku licencji" i wybierz jedno z poniższych programów.

    Intel® Quartus® Lite Edition

    Oprogramowanie programistyczne Intel Quartus z osłoną T-Guard

    Oprogramowanie programistyczne Intel Quartus dołączone do zestawu programisty

    Oprogramowanie deweloperskie Intel Quartus z serwerem licencji sieciowej

T-Guard to klucz sprzętowy lub klucz sprzętowy, który podłącza się do równoległego portu komputera.

Jeśli nadal potrzebujesz pomocy, wykonaj poniższe czynności.

Otwórz okno Konfiguracja licencji (menu Narzędzia -> Konfiguracja licencji). Pole Plik licencji musi mieć określoną ścieżkę do pliku licencji lub port@host serwera licencji. Jeśli chcesz przejść do pliku licencji, kliknij przycisk [. . .] i wybierz plik licencji na dysku twardym.

Przykłady prawidłowych wartości pól pliku licencji:

Ścieżka do pliku licencji: c:\quartus\license.dat

port@host: 1800@server1

Aby korzystać z oprogramowania deweloperczego Intel® Quartus® należy skonfigurować plik licencji. Możesz poprosić o plik licencyjny w witrynie firmy Intel, jeśli jeszcze go nie masz.

Aby uzyskać nowy plik licencyjny, zapoznaj się z poprzednią sekcją.

Jeśli plik licencji został już zainstalowany, sprawdź, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia.

Aby sprawdzić konfigurację pliku licencji, wybierz oprogramowanie poniżej i dowiedz się szczegółów.

Intel® Quartus® Lite Edition

Oprogramowanie programistyczne Intel Quartus z osłoną T-Guard

Oprogramowanie programistyczne Intel Quartus dołączone do zestawu programisty

Oprogramowanie deweloperskie Intel Quartus z serwerem licencji sieciowej

T-Guard to klucz sprzętowy lub klucz sprzętowy, który podłącza się do równoległego portu komputera.

Jeśli nadal potrzebujesz pomocy, wykonaj poniższe czynności.

Otwórz okno Konfiguracja licencji (menu Narzędzia -> Konfiguracja licencji). Pole Plik licencji musi mieć określoną ścieżkę do pliku licencji lub port@host serwera licencji.

Jeśli chcesz przejść do pliku licencji, kliknij przycisk [. . .] i wybierz plik licencji na dysku twardym.

Przykłady prawidłowych wartości pól pliku licencji:

Ścieżka do pliku licencji: c:\quartus\license.dat

port@host: 1800@server1

Oprogramowanie przestanie działać, jeśli plik licencyjny wygaśnie, a plik licencji mógł wygasnąć.

Pobierz nowy plik licencyjny omówiony w sekcji "Jak uzyskać nowy plik licencji".

Jeśli plik licencji nie wygasł, sprawdź, czy oprogramowanie programistyczne Intel® Quartus® jest skonfigurowane tak, aby wskazywało prawidłowy plik licencji w celu uruchomienia. Veirfy oprogramowanie jest skierowane do licencji lub zapoznaj się z sekcją "Jak sprawdzić konfigurację pliku licencji" na tej stronie.

Jeśli problem nadal występuje, wykonaj poniższe czynności:

Otwórz okno Konfiguracja licencji (menu Narzędzia -> Konfiguracja licencji). Pole Plik licencji musi mieć określoną ścieżkę do pliku licencji lub port@host serwera licencji. Jeśli chcesz przejść do pliku licencji, kliknij przycisk [. . .] i wybierz plik licencji na dysku twardym.

Przykłady prawidłowych wartości pól pliku licencji:

Ścieżka do pliku licencji: c:\quartus\license.dat

port@host: 1800@server1

Często zadawane pytania

Często zadawane pytania

W zależności od tego, kiedy plik licencyjny wygaśnie, do korzystania z nowej wersji oprogramowania może być potrzebny nowy plik licencji.

Zapoznaj się z sekcją "Jak uzyskać nowy plik licencyjny" na tej stronie.

W ramach procesu konfiguracji licencji należy określić lokalizację pliku licencji przy użyciu zmiennej systemowej LM_LICENSE_FILE.

Sprawdź, czy plik licencji umożliwia obsługę narzędzia DSP Builder dla układów Intel FPGA. Możesz dowiedzieć się, jakie oprogramowanie umożliwia Twoja licencja, sprawdzając w pliku licencyjnym - wiersze zaczynające się od FEATURE lub INCREMENT zawierają listę oprogramowania włączonego przez licencję. W przypadku procesora DSP Builder dla układów INTEL FPGA wymagany wiersz FEATURE zaczyna się od C4D5_512A. Na poniższej ilustracji przedstawiono przykładowy plik licencji.dat zawierający wiersz DSP Builder for Intel FPGA FEATURE (wyróżniony).

Plik licencji powinien zawierać wiersz FEATURE, aby włączyć obsługę narzędzia DSP Builder.

Jeśli nadal potrzebujesz pomocy, wykonaj następujące czynności:

Otwórz okno Konfiguracja licencji (menu Narzędzia -> Konfiguracja licencji). Pole Plik licencji musi mieć określoną ścieżkę do pliku licencji lub port@host serwera licencji. Jeśli chcesz przejść do pliku licencji, kliknij przycisk [. . .] i wybierz plik licencji na dysku twardym.

Przykłady prawidłowych wartości pól pliku licencji:

Ścieżka do pliku licencji: c:\quartus\license.dat

port@host: 1800@server1

Sprawdź konfigurację pliku licencji. Szczegółowe informacje można znaleźć w sekcji "Jak sprawdzić konfigurację pliku licencji".

Aby korzystać z narzędzia DSP Builder dla układów FPGA firmy Intel, należy skonfigurować plik licencji. Możesz poprosić o plik licencyjny ze strony internetowej firmy Intel, jeśli jeszcze go nie masz.

W ramach procesu konfiguracji licencji należy określić lokalizację pliku licencji przy użyciu zmiennej systemowej LM_LICENSE_FILE.

Sprawdź, czy plik licencji umożliwia obsługę narzędzia DSP Builder dla układów Intel FPGA. Możesz dowiedzieć się, jakie oprogramowanie umożliwia Twoja licencja, sprawdzając w pliku licencyjnym - wiersze zaczynające się od FEATURE lub INCREMENT zawierają listę oprogramowania włączonego przez licencję. W przypadku procesora DSP Builder dla układów INTEL FPGA wymagany wiersz FEATURE zaczyna się od C4D5_512A. Na poniższej ilustracji przedstawiono przykładowy plik licencji.dat zawierający wiersz DSP Builder for Intel FPGA FEATURE (wyróżniony).

Sprawdź, czy plik licencji zawiera wiersz FEATURE, aby włączyć obsługę dsP Builder. Jeśli go nie widzisz, skontaktuj się z działem obsługi klienta firmy Intel, aby uzyskać odpowiedni wiersz funkcji dla oprogramowania DSP Builder dla układów FPGA firmy Intel i ponownie wyemisować licencję.

Jeśli chcesz uzyskać nowy plik licencji, musisz poprosić firmę Intel o plik licencyjny i skonfigurować go, aby korzystać z narzędzia DSP Builder dla układów Intel® FPGA. Jeśli zakupiono zestaw DSP Development Kit, który zawiera narzędzie DSP Builder dla układów INTEL FPGA, wybierz odpowiednie łącze licencjonowania na podstawie zestawu deweloperycznego na stronie sieci Web licencjonowania oprogramowania Intel FPGA. Jeśli chcesz poprosić o licencję ewaluacyjną dla dsP Builder dla układów Intel FPGA lub zaktualizować licencję DSP Builder dla Intel FPGA (nowy komputer, przeniesienie do współpracownika itp.), Prześlij zgłoszenie serwisowe mySupport. Instrukcje dotyczące konfigurowania narzędzia DSP Builder dla licencji Intel FPGA znajdziesz w sekcji Konfigurowanie licencjonowania w informacjach o wersji DSP Builder.

Jeśli problem nadal występuje, sprawdź, czy zmienna środowiskowa LM_LICENSE_FILE musi wskazywać lokalizację pliku license.dat. Konfiguracja zmiennej środowiskowej zależy od systemu operacyjnego na komputerze.

Windows* NT: Określ lokalizację pliku licencji za pomocą LM_LICENSE_FILE w systemie Windows NT.
Ustaw zmienną środowiskową w panelu sterowania systemu Windows.
1. Wybierz Ustawienia -> Panelu sterowania z menu Start systemu Windows.
2. Kliknij dwukrotnie ikonę System w oknie Panel sterowania.
3. Kliknij Środowisko kartę w Oknie dialogowym Właściwości systemu.
4. Kliknij listę Zmienna systemowa, aby ją podświetlić.
5. Wpisz LM_LICENSE_FILE w polu Zmienna.
6. Wpisz \license.dat lub @ w polu wartości.
7. Kliknij przycisk Ustaw, a następnie kliknij przycisk OK.
Jeśli więcej niż jedna aplikacja używa tej zmiennej środowiskowej, zmodyfikuj istniejącą zmienną LM_LICENSE_FILE i oddziel różne ścieżki średnikiem (;), jak pokazano w poniższym przykładzie:
c:\flexlm\licencja.dat; 1800@myserver

Ustawianie LM_LICENSE_FILE w systemie Windows NT

Windows 2000 lub Windows XP: Określanie lokalizacji pliku licencji za pomocą LM_LICENSE_FILE w widoku klasycznego Panelu sterowania systemu Windows 2000 lub Windows XP.

Ustaw zmienną środowiskową w panelu sterowania systemu Windows.
1. Wybierz Ustawienia -> Panelu sterowania z menu Start systemu Windows.
2. Kliknij dwukrotnie ikonę System w oknie Panel sterowania.
3. Kliknij przycisk Zaawansowane kartę w oknie dialogowym Właściwości systemu.
4. Kliknij opcję Zmienne środowiskowe.
5. Kliknij listę Zmienna systemowa, aby ją podświetlić.
6. Jeśli LM_LICENSE_FILE już istnieje, wybierz Edytuj. W przeciwnym razie wybierz Nowy i wpisz LM_LICENSE_FILE.
7. Wpisz \license.dat lub @ w polu wartości.
8. Kliknij przycisk OK.
Jeśli więcej niż jedna aplikacja używa tej zmiennej środowiskowej, zmodyfikuj istniejącą zmienną LM_LICENSE_FILE i oddziel różne ścieżki średnikiem (;), jak pokazano w poniższym przykładzie:
c:\flexlm\licencja.dat; 1800@myserver

Ustawianie LM_LICENSE_FILE w systemie Windows 2000 lub Windows XP

Oprogramowanie przestanie działać po wygaśnięciu pliku licencji. Plik licencyjny mógł wygasić.

Musisz poprosić firmę Intel o plik licencyjny i skonfigurować go, aby korzystać z narzędzia DSP Builder dla układów INTEL® FPGA. Jeśli zakupiono zestaw DSP Development Kit, który zawiera narzędzie DSP Builder dla układów INTEL FPGA, wybierz odpowiednie łącze licencjonowania na podstawie zestawu deweloperycznego na stronie sieci Web licencjonowania oprogramowania Intel FPGA. Jeśli chcesz poprosić o licencję ewaluacyjną dla dsP Builder dla układów Intel FPGA lub zaktualizować licencję DSP Builder dla Intel FPGA (nowy komputer, przeniesienie do współpracownika itp.), Prześlij zgłoszenie serwisowe mySupport. Instrukcje dotyczące konfigurowania narzędzia DSP Builder dla licencji Intel FPGA znajdziesz w sekcji Konfigurowanie licencjonowania w informacjach o wersji DSP Builder.

W ramach procesu konfiguracji licencji należy określić lokalizację pliku licencji przy użyciu zmiennej systemowej LM_LICENSE_FILE.

Sprawdź, czy plik licencji umożliwia obsługę narzędzia DSP Builder dla układów Intel FPGA. Możesz dowiedzieć się, jakie oprogramowanie umożliwia Twoja licencja, sprawdzając w pliku licencyjnym - wiersze zaczynające się od FEATURE lub INCREMENT zawierają listę oprogramowania włączonego przez licencję. W przypadku procesora DSP Builder dla układów INTEL FPGA wymagany wiersz FEATURE zaczyna się od C4D5_512A. Na poniższej ilustracji przedstawiono przykładowy plik licencji.dat zawierający wiersz DSP Builder for Intel FPGA FEATURE (wyróżniony).

Sprawdź, czy plik licencji zawiera wiersz FEATURE, aby włączyć obsługę dsP Builder.

Jeśli problem nadal występuje, sprawdź, czy zmienna środowiskowa LM_LICENSE_FILE musi wskazywać lokalizację pliku license.dat. Konfiguracja zmiennej środowiskowej zależy od systemu operacyjnego na komputerze.

Windows* NT: Określ lokalizację pliku licencji za pomocą LM_LICENSE_FILE w systemie Windows NT.
Ustaw zmienną środowiskową w panelu sterowania systemu Windows.
1. Wybierz Ustawienia -> Panelu sterowania z menu Start systemu Windows.
2. Kliknij dwukrotnie ikonę System w oknie Panel sterowania.
3. Kliknij Środowisko kartę w Oknie dialogowym Właściwości systemu.
4. Kliknij listę Zmienna systemowa, aby ją podświetlić.
5. Wpisz LM_LICENSE_FILE w polu Zmienna.
6. Wpisz \license.dat lub @ w polu wartości.
7. Kliknij przycisk Ustaw, a następnie kliknij przycisk OK.
Jeśli więcej niż jedna aplikacja używa tej zmiennej środowiskowej, zmodyfikuj istniejącą zmienną LM_LICENSE_FILE i oddziel różne ścieżki średnikiem (;), jak pokazano w poniższym przykładzie:
c:\flexlm\licencja.dat; 1800@myserver

Ustawianie LM_LICENSE_FILE w systemie Windows NT

Windows 2000 lub Windows XP: Określanie lokalizacji pliku licencji za pomocą LM_LICENSE_FILE w widoku klasycznego Panelu sterowania systemu Windows 2000 lub Windows XP.

Ustaw zmienną środowiskową w panelu sterowania systemu Windows.
1. Wybierz Ustawienia -> Panelu sterowania z menu Start systemu Windows.
2. Kliknij dwukrotnie ikonę System w oknie Panel sterowania.
3. Kliknij przycisk Zaawansowane kartę w oknie dialogowym Właściwości systemu.
4. Kliknij opcję Zmienne środowiskowe.
5. Kliknij listę Zmienna systemowa, aby ją podświetlić.
6. Jeśli LM_LICENSE_FILE już istnieje, wybierz Edytuj. W przeciwnym razie wybierz Nowy i wpisz LM_LICENSE_FILE.
7. Wpisz \license.dat lub @ w polu wartości.
8. Kliknij przycisk OK.
Jeśli więcej niż jedna aplikacja używa tej zmiennej środowiskowej, zmodyfikuj istniejącą zmienną LM_LICENSE_FILE i oddziel różne ścieżki średnikiem (;), jak pokazano w poniższym przykładzie:
c:\flexlm\licencja.dat; 1800@myserver

Ustawianie LM_LICENSE_FILE w systemie Windows 2000 lub Windows XP

Materiały zawarte na tej stronie są tłumaczeniem z języka angielskiego, wykonanym częściowo przez człowieka, a częściowo automatycznie. Materiały te są udostępnione dla Twojej wygody i należy je traktować jedynie jako ogólne źródło informacji. Nie ma jednak gwarancji, że są one kompletne bądź poprawne. Jeśli istnieje jakakolwiek rozbieżność między wersją angielską tej strony a jej tłumaczeniem, wersja angielska jest wersją obowiązującą i ma rozstrzygające znaczenie. Wyświetl anglojęzyczną wersję tej strony.